Stuck on 1500 rpm, VP TAMD63p

krhe00

New member
Joined
13 Nov 2020
Messages
1
Visit site
Hi! I'd appreciate some troubleshooting advice on my engine problems.

Engines:
2xVolvo Penta TAMD63p (in Fairline 43 Targa)

Problem:
Stuck on 1500 rpm (for about 45 sec) until engines/turbos eventually builds up power in and boat goes in plane.

Background:
During winter both engines were taken out as two new fuel tanks were put in.
Engines was serviced while out. Injectors, nozzles, heads and gaskets were renovated/changed (among other things). New fuel and oil filters.


Usually it will take the engines/turbos about 5 seconds to build up power and go from 1500 rpm to max at about 3200 rpm. The engines worked fine before the service.

Now, after the service, the power get stuck at 1500 rpm, even with full throttle for a long long time (about 45 sec) before engines/turbos will give power and rev up.
At low rpm's everything seems fine. Once revved up, I get lots of power.

I'd like to get some advice and inspiration on where to look.
With new tanks, it might be the fuel system and with the engine service done it might be the injectors or something else.
Sure, it might be something wrong with the turbos, but as said, they worked fine before the service and as far as I know they haven't been touched.

Based on the fault pattern, is it reasonable to think it got something to do with the fuel system (to little fuel, air leakage) or is it most likely in the engine side?
Where should I direct my attention?

Thanks in advance!
 

Bandit

Well-known member
Joined
30 Jun 2004
Messages
3,556
Location
Guernsey
Visit site
It could be anything, a worn stuck Turbo, waste gate, sucking air in fuel system. If propped correctly the 63 p should rev to about 2800 to 2950 not 3200.
 

kashurst

Well-known member
Joined
10 Oct 2003
Messages
10,982
Location
Spain
Visit site
worn turbo and or the turbo wastegate mechanism. check out the rubber pipe connecting the turbo to the inlet manifold and its clamps too. With help try and find inlet manifold leaks too when running at 1500 rpm. Any unusual whistling noises

plumb a boost pressure gauge into the inlet manifold to see what is happening.
 

jrudge

Well-known member
Joined
4 Dec 2005
Messages
5,347
Location
Live London, boat Mallorca
Visit site
The challenge is so much has been done. I would get a vodia on it and see what is going on.

Logically ( not that boats and engines follow much logic ) it will be a turbo / waste gate issue as once it gets there it works.
 
Top