5.7 ltr Vilevo

BarryH

Active member
Joined
31 Oct 2001
Messages
6,936
Location
Surrey
Visit site
Got hold of one cheap. Rebuilt it from the crank up. It'll run if running straight thru pipes but doesn't want to know if routing the exhaust thru the drive. The drive is a 280 and I know volvo used these with the V8's.

The compression is good its been rebored etc etc. The starter turns with no problems. What am I missing?

I gave up on the diesel option.....waste of time..
 

dpb

Well-known member
Joined
14 Feb 2007
Messages
1,193
Location
Poole, Dorset
Visit site
If the drives were used previously on a boat with through transom exhaust, then the exhaust passage on the drive may be blanked off with a plate. Or the flaps that prevent water ingress back through the drive exhaust may be corroded shut. (On Mercs these flaps are on the down pipes to the legs, don't know how Volvo do this but there will be a sililar arrangement I would think)
 

BarryH

Active member
Joined
31 Oct 2001
Messages
6,936
Location
Surrey
Visit site
The outdrive is fine. Its the original on my boat. The 145 4 pot had no problems with it. The exhaust and water runs fron the exhaust outlet when running on muffs but it won't run when the boat is in the water.

I rigged some straight tru pipes and it runs fine. The sound of an unsilenced V8 is fine for 5 mins but would annoy the hell out of me for any period of time.

This is a swap for my original lump. The only things that have changed on the drive is the cow horn exhaust fitting/bell housing. I changed the bellows on both the UJ and the exhaust....yes it is fitted the correct way round.

Theres plenty of compression and the starter turns the engine over no problem at all. The engine has been rebuilt by me having come back from a rebore with new pistons rings etc.
 
Top