Jabsco Sea Toilet - Pump assembly leaks if flush is open

Jokani

Active member
Joined
21 May 2014
Messages
805
Visit site
Jabsco Model 29090

I purchased a service kit and fitted this over the winter. A job I was not looking forward to undertaking for the first time, but it did not take as long as expected and was relatively pain free.

But..

Tested for the first time on the water last week. If I pump the handle whilst the flush control lever is closed the toilet empties OK.

If I switch the flush control lever to the open position, instead of pumping water in to the bowl, the water leaks out from the top of the pump assembly, through the screws in the valve cover.

Any ideas what I could have done wrong, and the easiest /best fix?
 

Jokani

Active member
Joined
21 May 2014
Messages
805
Visit site
That sounds good, so not a total failure, either tighten the screws, or just remove the valve cover and re-seat the valve cover.

I was worried there was something more serious.

I'll give that a go at the weekend and let you know hoe I get on.
 

Ruffles

Active member
Joined
26 Feb 2004
Messages
3,044
Location
Boat: Portsmouth, Us: Stewkley
www.soulbury.demon.co.uk
From memory some of the service kits come with screws that are slightly too long. Is it actually compressing the gasket? Try trapping a piece of dental floss in the seal and see if you can pull it out easily.

PS: Just viewed the video. Isn't it civilised working on a pristine loo with no poo in it!
 
Last edited:

Other threads that may be of interest

Top