Raymarine 2Kw Radome

tamara

New member
Joined
11 Dec 2005
Messages
64
Location
Blyth Northumberland at the moment
www.seagipsy.co.uk
Has anyone experienced problems with Raymarine radomes switching them selves off after about 3 or 4 minutes. I have fitted the C80 with 2Kw dome and all other Raymarine equipment. The problem started when my IP68 Deck plug took in water on a night sail to Lowestoft, after drying the plug and cleaning the pins with electrical cleaner I got the dome to transmit again, but continues to switch off. I have also reset the entire system and tried looking at all the menu settings, Anyone got any ideas. My next port of call is Shotley Point Harwich,
any help or ideas please. /forums/images/graemlins/mad.gif
 

Phoenix of Hamble

Active member
Joined
28 Aug 2003
Messages
20,972
Location
East Coast
mishapsandmemories.blogspot.com
Not really.... but if it is any consolation or help, the boatyard at Shotley has a good reputation and a decent network of reliable contacts for specialist work....

When are you in to Shotley? If I am around, would be happy to help with lifts to various sources of help....
 

BlueSkyNick

Active member
Joined
29 Apr 2003
Messages
11,766
Location
Near a marina, sailing club and pub
Visit site
This happened to me once when crossing the channel, because the battery voltage dropped to a certain level (can't remember what). Its a feature to prevent you running the battery too flat.

As soon as I switched to the second battery, the radar behaved itself - I just wish I hadnt been in the shipping lanes at the time !
 

roly_voya

New member
Joined
5 Feb 2004
Messages
1,050
Location
Pembrokeshire Wales
Visit site
Leachers comment makes me wonder if you have a high resistance short, enough to nock voltage down to below cut out but not enough to blow fuse. Can be caused by salt residue in deck plugs. Can also get the same effect due to resistance through poor contacts. Try measuring the voltage above the deck plug under load. If the plug has been leaking poor contacts sounds quite possible. Through deck glands and below deck plugs are much more reliable
 
Top