KAD 32 loss of power, help please

georgehes

New member
Joined
3 Jun 2007
Messages
5
Location
Cumbria
Visit site
Hi, I'm new here and would like some help please. I have a Regal 2250 with a KAD 32. Been great for 1 month since I got her but now has lost power. I can only get 3000rpm instead of 3900rpm with corresponding loss of initial power, slower acceleration and reduced top end. Any help is appreciated. Thanks, George
 

spannerman

Well-known member
Joined
30 Nov 2002
Messages
3,135
Visit site
As stated change the fuel filters and check the air filter while your at it.
Is the compressor cutting in around 1500-1700 rpm and out at 2300-2500 rpm.
If everything checks out, then remove either the inlet or exhuast bend on the turbo and check if spins freely and if there is excessive play on the shaft, a minute amount is normal but if its 1 or 2 mm +, then it needs overhaul/replacment.
 

georgehes

New member
Joined
3 Jun 2007
Messages
5
Location
Cumbria
Visit site
Guys...Many thanks for the guidance, I have ordered a new fuel filter today. Tested her in neutral and full power is available. So the fault is only when under load. She has only been in the water 2 months so is not what I would call fouled up underneath.
 

neale

Active member
Joined
30 May 2001
Messages
3,658
Location
Essex Mud and Solent
Visit site
[ QUOTE ]
Guys...Many thanks for the guidance, I have ordered a new fuel filter today. Tested her in neutral and full power is available. So the fault is only when under load. She has only been in the water 2 months so is not what I would call fouled up underneath.

[/ QUOTE ]

Have you actually looked underneath. I have got enough fouling on my boat in three months to stop it going above 11 knots. Normal top speed was 35 knots.

Another option is wrong size prop. Have you witnessed the boat at full power with the current prop?

More technical issues could be fuel starvation or Turbo propblem as already mentioned. Check the integrity of all the pipework connections off the turbo. It may be working fine, but if the charged air is leaking, you will suffer loss of power.
 

georgehes

New member
Joined
3 Jun 2007
Messages
5
Location
Cumbria
Visit site
She has some very minor slime underneath. Not enough to restrict her to 75% FSD on the RPM. She has operated at full power since I bought her in March so I know she is capable of a better rate of acceleration and top end. I will change the fuel filter and air connections then report back.
 

hlb

RIP
Joined
16 May 2001
Messages
26,775
Location
Any Pub Lancashire or Wales
Visit site
Check for bug in the fuel whilst changing filter, pour it into a wine glass, it should be cristal clear. If brown'ish/ black'ish lumps. Bug, so dose with Soltron, or your favourite ilixior.
 

georgehes

New member
Joined
3 Jun 2007
Messages
5
Location
Cumbria
Visit site
I've changed the fuel filter, diesel was clear but I've added fuel treatment anyway. I've had a mask on and tonight been under her in the open sea to assess her bottom. No weed growth on the hull, just some very minor slime. About 20 barnacles on the leg say 10mm across and some minor weed there too, but just some whispy strands. She has settled out at 3700rpm FSD and 39 mph. Accelerated fine and pulled my 12yr out of the water on a pair of skis...I guess that means she is ok again as she is in the fsd rev range. I will monitor her performance.
 
Top