Garmin 72 dead?

brownsox

Member
Joined
15 Jul 2004
Messages
377
Location
London
Visit site
We left our Garmin on the boat over winter, in its case, inside a sealed box, no damp at all. but it will not respond at all now. Tried looking in v bright light in case contrast problem but nothing. Rang Garmin they said try holding menu while switching on. Nothing. They have no other suggestions. Has anyone had a similar problem? Any suggestions? Loathe to just go and buy another but cannot wait while it is shipped away for repair. We are currently in La Roche Bernard on the Vilaine heading for Morbihan next. Thanks for any help.
 

sarabande

Well-known member
Joined
6 May 2005
Messages
35,948
Visit site
Silly question, but have you replaced the internal batteries. There's a small current drain to maintain internal processes....
 

Birdseye

Well-known member
Joined
9 Mar 2003
Messages
28,156
Location
s e wales
Visit site
for the sake of the cost of the post, send the set off to Garmin telling them it has failed. They have a first class rep for service, and are likely simply to replace. No garauntees of course, but worth the postage.
 

William_H

Well-known member
Joined
28 Jul 2003
Messages
13,704
Location
West Australia
Visit site
With a totally dead GPS ie no markings on the screen the fault is most likely in the battery contacts. I presume it has batteries.
Clean the contacts with fine sand paper or wet and dry paper and ensure there is plenty of end pressure on the cells.
If you get no image at all on the screen and it is not battery contacts then send it back to Garmin. Buy a spare if you are ina hurry.
If you have OK screen but no lock on then that is simply because it has been inactive too long it just takes time. Several hours max.
Sorry my answer is in terms of my experience with Etrex.
good luck olewill
 

brownsox

Member
Joined
15 Jul 2004
Messages
377
Location
London
Visit site
Many thanks as ever for those replies. in fact we ended up getting a new one and when back in the UK we will send it back to Garmin. It was weird because when we left it with batteries in they lost charge but still no sign of anything on the screen.
 
Top