• REMINDER

    Any content, information, or advice found on social media platforms and the wider Internet, including forums such as YBW, should NOT be acted upon unless checked against a reliable, authoritative source, and re-checked, particularly where personal health and liberty is at stake. Seek professional advice/confirmation before acting on such at all times.

    Users who are found to promulgate FAKE NEWS on the forum in regard to this issue, intentional or otherwise, may find their access terminated. It is your responsibility to provide references to bona fide sources.

    FAKE NEWS, in this regard, is that which is posited by organisations, media, etc., that is repeated on the forum, or used to support personal opinion/hypothesis posted by users - FAKE NEWS is not necessarily the personal opinion/hypothesis being posted in itself, any issues with such should be challenged respectfully.

Setting up a Navik windvane

jasperthedog

Member
Joined
3 Oct 2006
Messages
78
Location
Leicestershire
Good evening All,

I,m just about to fit a Navik windvane to my yacht, bought second hand already put together. I have it set up on framework
So i can see how it works and a bit of a service.
One thing i,m not sure on is how much the trim tab should turn, moving the top vane from completely vertical to fully locked over
Only moves the trim tab about 10 degrees.
Does this sound correct, there doesnt seem to be any excessive play in any parts.

Tia, Richard.
 

Yellow Ballad

Well-known member
Joined
10 Oct 2013
Messages
1,247
Location
Shropshire - Sundance, Bristol Channel
You've got me doubting myself....I'm not sure if I'm describing/understanding correctly. When in the neutral position the dowel is about an inch alond the slot, forward to aft. It doesn't actually need to move a lot as the rudder does the swing, the trim tab just directs it. I'll get some pictures next time I'm down the boat if no one can clarify beforehand.
 

jasperthedog

Member
Joined
3 Oct 2006
Messages
78
Location
Leicestershire
Thanks YB, that helps a lot. It looks like yours is moving about a third more than mine. I seem to have a bit of play in the small stainless connecting pin so I'll investigate that first.
Thanks again for your help much appreciated.
Rich.
 
Top