• REMINDER - COVID-19

    Any content, information, or advice found on social media platforms and the wider Internet, including forums such as YBW, should NOT be acted upon unless checked against a reliable, authoritative source, and re-checked, particularly where personal health and liberty is at stake. Seek professional advice/confirmation before acting on such at all times.

    Users who are found to promulgate FAKE NEWS on the forum in regard to this issue, intentional or otherwise, may find their access terminated. It is your responsibility to provide references to bona fide sources.

    FAKE NEWS, in this regard, is that which is posited by organisations, media, etc., that is repeated on the forum, or used to support personal opinion/hypothesis posted by users - FAKE NEWS is not necessarily the personal opinion/hypothesis being posted in itself, any issues with such should be challenged respectfully.

    IN ADDITION it seems that conspiracy theories are finding their way onto the forum. This is not the place for such content. Users who post it may find their access limited or permanently suspended. Please leave it where you find it.

Matsutec HP-33A AIS Transponder: Firmware Update

Deep 6

New member
Joined
19 May 2016
Messages
6
Hello A 22 - I uploaded the 2015 firmware thanks to Nigel's easy to follow step by step instructions.
I think it is a few minor bug fixes - one I noticed is the date is now on own dynamic info page - missing on mine before. My unit does not transmit and I was hoping the firmware update would sort this but no luck. The MMSI number has been correctly input and the TX is in the on position in the AIS set up page - anyone any ideas before I send back to HK?
 

BlueChip

Active member
Joined
24 Aug 2004
Messages
4,838
Location
Bucks/Plymouth
Hello A 22 - I uploaded the 2015 firmware thanks to Nigel's easy to follow step by step instructions.
I think it is a few minor bug fixes - one I noticed is the date is now on own dynamic info page - missing on mine before. My unit does not transmit and I was hoping the firmware update would sort this but no luck. The MMSI number has been correctly input and the TX is in the on position in the AIS set up page - anyone any ideas before I send back to HK?
Unless you are moving, it wont transmit your position for some time.
Are you sure you left it for long enough?
Are you sure you have the antenna cables plugged in the correct sockets?
 

Deep 6

New member
Joined
19 May 2016
Messages
6
Tried with two vhf aerials which have been proved good and checked Marine Traffic plus a couple of local mfvs
 

Deep 6

New member
Joined
19 May 2016
Messages
6
Powered up for over 24hrs and not possible on connection side as all are different types
 

superheat6k

Well-known member
Joined
10 Jan 2012
Messages
5,871
Location
South Coast
My HP-620A would not transmit on the default setting of SO-TDMA (class A use), but seems fine on CS-TDMA (class B use) setting.
 

jbees

New member
Joined
26 Feb 2014
Messages
4
Just read your 2014 post with description of link cable connections which I have found very useful, thanks. Do you know if the HP-33A needs the 5v USB supply in addition to its normal 12v connection?
 

pvb

Well-known member
Joined
16 May 2001
Messages
42,763
Location
UK East Coast
Just read your 2014 post with description of link cable connections which I have found very useful, thanks. Do you know if the HP-33A needs the 5v USB supply in addition to its normal 12v connection?
You'll see there's "RIP" under Nigel's username on that post. Sadly he died some time ago.
 

Deep 6

New member
Joined
19 May 2016
Messages
6
No as far as mine is concerned, Just standard 12v supply. Re below message chain it turned out I had a faulty unit which Matsutec replaced FOC after quite a few emails with their tech dept, has been working fine since.
 

North Side

New member
Joined
29 Nov 2018
Messages
1
Hi guys, I need help. My AIS device HP33-A is mixing VDO and VDM sentences from my own ship, so the plotter is continuously sounding the collision alarm with myself. Does it happen to you?, Do you know if this issue is removed by changing the firmware?, Where can I find a recent firmware?.

Here is a sample of the NMEA sentences:
! AIVDO, 1,1 ,,, H3aQ5whpu9 @ R1 <T @ F22222222206,0 * 41
! AIVDO, 1,1 ,,, H3aQ5whpu9 @ R1 <T @ F22222222206,0 * 41
! AIVDM, 1,1,, A, H3aQ5whpu9 @ R1 <T @ F2222222220,2 * 36
! AIVDO, 1,1 ,,, H3aQ5wlT <wwJ1D9 @ 2lpnlP1H040G, 0 * 58
! AIVDM, 1,1,, A, H3aQ5wlT <wwJ1D9 @ 2lpnlP1H040G, 0 * 1B
! AIVDO, 1,1 ,,, H3aQ5wlT <CPaF0I @ 2lpnlP1H0403,0 * 67
! AIVDM, 1,1,, A, H3aQ5wlT <CPaF0I @ 2lpnlP1H0403,0 * 24

Any help will be welcome. Best regards from southeast coast of Spain
 

toucancatketch

New member
Joined
12 Mar 2015
Messages
6
Location
Rio Vista USA
I have had the same issue with my hp33a. I have posted here and elsewhere looking for a solution but never got a response. This isn't an issue where your plotter has the option to filter your own mmsi. Mine is an old Garmin no longer supported and no filter.

My work around is that my system uses a mux and I can do some editing of the stream. When it sees my mmsi the data is edited to move me to the North Pole. Not pretty but it gets the false target off the screen.

I wrote a simple Arduino script that actually does the filter, but the wiring is iffy and I lost interest.

I'd love to see a real answer.
 
Last edited:

kevinliu1975

New member
Joined
28 Dec 2019
Messages
1
Location
Honolulu, HI
anyone still have the firmware for the matsutech hp-33a? can someone share it, my unit is has a corupted firmware and need to be reload
please help!!!! many thanks
 

unbilba

New member
Joined
24 Jun 2020
Messages
10
Hello A 22 - I uploaded the 2015 firmware thanks to Nigel's easy to follow step by step instructions.
I think it is a few minor bug fixes - one I noticed is the date is now on own dynamic info page - missing on mine before. My unit does not transmit and I was hoping the firmware update would sort this but no luck. The MMSI number has been correctly input and the TX is in the on position in the AIS set up page - anyone any ideas before I send back to HK?
Hello Deep6:



Looking for information to solve my problem with my Hp33a, I found this post. In this post you mentioned you upload de firmware to the device.


Do you still have the file ? Could you share with me please?



Thanks
 
Top