• UPDATED INFORMATION & ADVICE - PLEASE READ NOW

    'I didn't know/I wasn't told' will not be a valid defence if you fail to comply and lose your access to the off-topic area, core topic areas, or the entire YBW forum as a result. Full details can be found here, please read before you proceed.

B & g network 496 mhu wind sender / vane

Flier2

Member
Joined
13 Nov 2015
Messages
34
Mine just started on the blink - Dont really want to get rid of old sytem - ive got it all working with a b & g vulcan plotter nmea 2k
using an actisense nmea converter - All wind speeds are fine but angle is inconsistent - i probably only need the small internals but happy to
pay for complete vane , cheers john
 

shortjohnsilver

Active member
Joined
22 May 2017
Messages
161
The B&G 496 MHU is obsolete and over recent years second hand units have become extremely difficult to get hold of. There are plenty of threads across the forums that talk about this particular bit of kit.
As you say if it forms part of a networked system then you really want to keep it going and replacement through people like B&G and Tinley Marine is extortionate and in my case untenable.
Last year my wind unit starting misbehaving, giving at first spurious wind angles, then the wind speed packed up. I climbed the mast and retrieved the MHU and took the thing apart. There was a little evidence of corrosion on some of the spot soldered points on the PCB within the unit and cleaning these failed to rectify the problem. Eventually, I purchased a replacement PCB and this is not cheap by any means and after going back up the mast swapped out the old PCB for the new!
So far so good!
At £350 or thereabouts for the PCB it was a bit of a gamble, as frankly I could have bought a stand alone wind system for less, but as you say wanted it to fit in with the network. But much cheaper than a new replacement vane MHU
Anyway, every time I switch it all on I still expect to see problems, but so far okay.
 

Flier2

Member
Joined
13 Nov 2015
Messages
34
Hi John , Thanks for the reply - this is my second dodgy vane - i did read all the forums couple of years ago and got lucky ( or not lol!)
on ebay . The rest of the network system has been superb (well apart from a flooded fluxgate compass)
i am going to keep looking for a lucky replacement if no joy i will attempt to back integrate a b& g 2k nmea vane into the system.
 

Flier2

Member
Joined
13 Nov 2015
Messages
34
update- Finally had respose from b & g who say it’s probably the pcb- Unfortunately they rekon not possible to back integrate
the new 310/320 vanes into old network - not sure he is up to speed on the actisense that can go both ways Asked for clarity.

so still looking for mhu 496 vane the perfect soloution
 

shortjohnsilver

Active member
Joined
22 May 2017
Messages
161
Good luck with that! I went for the PCB option and all okay. Not cheap but cheaper than a replacement 496 MHU, which are few and far between. All the best.
 

Flier2

Member
Joined
13 Nov 2015
Messages
34
Great news , managed to get in quick on a 7 piece network system off ebay. Fingers crossed it works
 
Top